Delete


There is no password for this article, only an administrator can delete the article.

Do you really want to delete this article?

Enter the password for this article, then click the "Delete" button. Click the "Cancel" button to exit this page.


Question - Prevent reencoding when creating BRMV No.66506
LiveRock  Mail / Home )  2012-08-10 11:45:45 ( ID:r//utnrtoxa )  

Hi

I am trying to create source files (.h264, mp4, etc) that Authoring Works 5 can use in a project to create a BDMV (Blu-way) disc.

However, I tried, Works 5 always try to reencode my source videos.
My source videos are

1920x1080
25 fps
H.264

The reencoding takes a lot of time; between 1-2 hours. If I add the Blu-ray writing, it is even more!

Is there a way to create source video files that avoid reencoing?

Thanks in advanced for any insights..


tkrave  2012-08-11 02:16:00 ( ID:esk4fdefcg2 )  

There may be other settings you need to change in order to conform to Blu-ray standards. Post the full details of your source file if you can; you can use a program called MediaInfo to get a detailed report.


LivrRock  Mail /  )  2012-08-12 18:09:29 ( ID:r//utnrtoxa )  

Here are the info, hope someone would tell me what's wrong:

General
Complete name : O:\JEC2012\tests\Conference Wind.264
Format : AVC
Format/Info : Advanced Video Codec
File size : 147 MiB
Overall bit rate mode : Variable

Video
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L4.0
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Format settings, GOP : M=4, N=24
Bit rate mode : Variable
Maximum bit rate : 18.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Interlaced
Scan order : Top Field First
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709


Maggi  2012-08-22 00:17:49 ( ID:pzgifoyf6pk )  

I'm running into the same problem here ...

I generated BluRay compliant TS streams with x264 and want to author those using TAW5, but no matter what settings I try, it always reencodes the whole programm.

So far, I tested the following options:
- "prevent this track from the target size adjustment"
- "output setting" -> automatic (smart rendering prioritized)

Am I missing some ther options here ?

However, using tsMuxeR for outputting those file as BD works just fine and every player I tried accepts those disks, but obviously, tsMuxeR has no option for authoring at all.


Stream details are as follows:

General
ID : 1 (0x1)
Complete name : Heimat_1.ts
Format : MPEG-TS
File size : 11.8 GiB
Duration : 46mn 1s
Overall bit rate mode : Variable
Overall bit rate : 36.6 Mbps
Maximum Overall bit rate : 35.5 Mbps

Video
ID : 4113 (0x1011)
Menu ID : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 3 frames
Codec ID : 27
Duration : 46mn 2s
Bit rate mode : Variable
Bit rate : 35.8 Mbps
Maximum bit rate : 40.0 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.691
Stream size : 11.0 GiB (94%)
Writing library : x264 core 116 r2057 0ba8a9c
Encoding settings : cabac=1 / ref=1 / deblock=1:-1:-1 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / sliced_threads=0 / slices=4 / nr=0 / decimate=1 / interlaced=fake / bluray_compat=1 / constrained_intra=0 / bframes=3 / b_pyramid=1 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=0 / keyint=100 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=abr / mbtree=1 / bitrate=35840 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=40000 / vbv_bufsize=30000 / nal_hrd=vbr / ip_ratio=1.40 / aq=1:1.00

Audio
ID : 4352 (0x1100)
Menu ID : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Codec ID : 129
Duration : 45mn 31s
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 16ms
Stream size : 146 MiB (1%)
Language : German

...

IMHO, this issue needs to get resolved asap

Regards,
Maggi


Maggi  2012-09-04 23:31:31 ( ID:pzgifoyf6pk )  

I would surely appreciate any kind of feedback on this matter ...

On a side note, I noticed the transcoding process causes the videolevels to be ajusted from full to legal levels and that's a major show stopper, since I'm usually working with video legal levels in my clips already.

Regards,
Maggi


tkrave  2012-09-05 05:53:30 ( ID:esk4fdefcg2 )  

Probably a bug related to PAL/25fps Blu-ray files.

I would contact support and give them the video info.
http://tmpgenc.pegasys-inc.com/en/support/support.html


Maggi  2012-09-05 19:02:20 ( ID:pzgifoyf6pk )  

Thanx, tkrave !

I just filed a bugreport.

I thought this BBS would be monitored and assisted by tech support, but now it seems, this is just user based.

Anyways, if I get this issue resolved, I'll drop a note.

Cheers,
Maggi


Maggi  2012-09-10 16:39:09 ( ID:pzgifoyf6pk )  

Just a little update:

I'm in talks with tech support, but didn't get too much technical details about mandatory requirements for a given h264 stream to avoid re-encoding.

BUT, I did some more research a found a working x264 encoder setting for 1080p25 footage, that does not get re-encoded by TAW at all:

x264.exe --no-progress --preset slow --tune film --nal-hrd vbr --weightp 2 --b-pyramid strict --bluray-compat --level 41 --keyint 25 --min-keyint 25 --aud --non-deterministic --slices 4 --bframes 2 --ref 1 --psy-rd 1:0 --fake-interlaced --bitrate 16000 --qcomp 0.6 --sar 1:1 --threads 0 --colorprim "bt709" --transfer "bt709" --colormatrix "bt709" --bframes 2 --vbv-maxrate 40000 --vbv-bufsize 30000 --b-pyramid strict --demuxer raw --input-res 1920x1080 --fps 25 --input-csp i420 -o output.264 input.file

Feel free to take these settings as a starting point for adopting it to your footage's specs ... :)

Best regards,
Maggi


tkrave  2012-09-11 07:15:22 ( ID:esk4fdefcg2 )  

Nice! Thanks for those specs. It was probably some minute setting that was throwing things off, though it could just be a bug too. The official Blu-ray whitepaper doesn't go into enough detail to help.
http://www.blu-raydisc.com/assets/Downloadablefile/BD-ROM-AV-WhitePaper_110712.pdf

I think Pegasys does monitor this forum but they won't respond, so I recommend that people contact support if they want a response or if they want to make sure a request/bug is seen.


Maggi  2012-09-17 19:54:18 ( ID:pzgifoyf6pk )  

Thanx for the link, tkrave !

In the PDF you linked, is a note about the needed format on page 33:

6.2.1 Video stream
Video streams for Blu-ray 3D shall be MPEG-4 MVC video format (Annex H of ITU-T H.264 | ISO/IEC 14496-10) compliant.


I dug a little deeper and found the following ITU paper that they are referring to:

http://www.itu.int/rec/T-REC-H.264.1/en

"Annex H" starts on page 604 ... ^^

But to make it short, that book is total overkill to read, so I'll keep it pragmatical and take the trail and error approach.

Right now, I'm trying to encode a 23.976p stream that's supposed to not get reencoded and I'll post the setting, once I'll find them to be compatible with TAW.

Cheers,
Maggi


Rick0725  2012-09-19 11:29:05 ( ID:abhw2jbwy1g )  

x264.exe --no-progress --preset slow --tune film --nal-hrd vbr --weightp 2 --b-pyramid strict --bluray-compat --level 41 --keyint 25 --min-keyint 25 --aud --non-deterministic --slices 4 --bframes 2 --ref 1 --psy-rd 1:0 --fake-interlaced --bitrate 16000 --qcomp 0.6 --sar 1:1 --threads 0 --colorprim "bt709" --transfer "bt709" --colormatrix "bt709" --bframes 2 --vbv-maxrate 40000 --vbv-bufsize 30000 --b-pyramid strict --demuxer raw --input-res 1920x1080 --fps 25 --input-csp i420 -o output.264 input.file

where do you enter these settings. I am having the same problem with .264 files.


Maggi  2012-09-20 20:26:53 ( ID:pzgifoyf6pk )  

that depends on what software you are using ... my example is for the cmd-line version of x264.exe, but I'd think that every GUI frontend for x264 has an option for entering those parameters as well

so, what are you using ?

Cheers,
Maggi


tkrave  2012-09-21 02:57:38 ( ID:esk4fdefcg2 )  

If you're using TVMW5, you need to select "MPEG file output" to access the advanced h.264 settings. It's a bit difficult to figure out which settings match those parameters though.


Rick0725  2012-09-26 11:33:55 ( ID:abhw2jbwy1g )  

I tried all possible settings MP4, M2TS, and TS in the HDPVR and NONE of the files smart rendered in Authoring Works 5. A TS file created a few years ago from the HDPVR did smart render though.

the difference in the video properties were

The 720p/59.94 TS file from a few years ago that smart rendors shows ...nonmbaff.

I noticed thata TS file buff=4, ref=4,nonmbaff smart rendors but buff=2, ref=2, nonmbaff does not smart rendor

The TS 1080i/60 file that does not smart rendors shows both...mbaff, nonmbaff


View article | Back to TMPGEnc Home | Administrator TMPGEnc Net

Script written by TMPGEnc.